Du bist nicht angemeldet.

derlucifer

Anfänger

Beiträge: 10

Registrierungsdatum: 26. Oktober 2018

  • Private Nachricht senden

281

Mittwoch, 31. Oktober 2018, 17:30

Wenn deine Pumpe noch funktioniert (extern mit 12V testen, ob sie anläuft) , könntest du das ganze System probehalber zurück bauen und beim nächsten Kaltstart bzw. durch zusammen stecken der beiden gründen Stecker im Fahrerfußraum und anschließend "Zündung an" testen, ob die Pumpe anläuft. Wenn ja, hängt das Problem irgendwie mit der Einbindung deiner Schaltung zusammen.
Ja, ich könnte die Pumpe mal testen, das ist richtig. Was ich allerdings schon gemacht habe ist, das ich im Originalzustand am Pumpenrelais mit einem Multimeter gemessen habe während des startens (Kabel oberhalb an die Kontakte des Relais gelötet damit man messen kann). Da waren leider auch keine 12V zu sehen.

Knoten

Fortgeschrittener

Beiträge: 180

Registrierungsdatum: 22. Mai 2014

  • Private Nachricht senden

282

Mittwoch, 31. Oktober 2018, 23:30

Im warmen oder kalten Zustand?
Kannst du sicher gehen das die Pumpe hätte anspringen müssen? Das Zeitfenster ist ja nicht wirklich groß.
Ich meine das sind etwa 20 Sekunden. Bin mir da nicht ganz sicher.

Ich guck mal ob ich die passenden Pläne auch auf diesem Rechner habe.
# Forester 2.0X SG Schalter [ MJ2007 ]

derlucifer

Anfänger

Beiträge: 10

Registrierungsdatum: 26. Oktober 2018

  • Private Nachricht senden

283

Donnerstag, 1. November 2018, 12:11

Ja, ich habe das immer im kalten Zustand getestet. Meistens über Nacht stehen gelassen und bei den aktuellen Temperaturen (4°C) sollte das System eigentlich anlaufen.

Wäre natürlich echt klasse wenn du was an Plänen finden würdest!

Knoten

Fortgeschrittener

Beiträge: 180

Registrierungsdatum: 22. Mai 2014

  • Private Nachricht senden

284

Donnerstag, 1. November 2018, 14:48

Dassollte dann ja durchaus reichen.
Hast PM
# Forester 2.0X SG Schalter [ MJ2007 ]

derlucifer

Anfänger

Beiträge: 10

Registrierungsdatum: 26. Oktober 2018

  • Private Nachricht senden

285

Donnerstag, 1. November 2018, 16:31

Super, vielen Dank für den Schaltplan.

So wie ich das da heraus lese, ist kommt der Schaltstrom direkt von der ECU und ist zwischendrin noch mit einem Stecker getrennt.
Das heißt ich muss den Stecker finden und das Richtige Kabel an der ECU (Diese ist glaube ich im Beifahrer Fußraum, oder?), dann kann ich dort weiter messen bzw. ob Durchgang von der ECU zum Relais ist.
Wenn nicht muss ja das Kabel einen defekt haben. Wenn ja bedeutet das vielleicht, das die ECU einen weg hat.

So müssten meine Vermutungen richtig sein, oder?

Knoten

Fortgeschrittener

Beiträge: 180

Registrierungsdatum: 22. Mai 2014

  • Private Nachricht senden

286

Donnerstag, 1. November 2018, 18:24

Nein. Das läuft doch noch über ein Relais.
Deine Pumpe hast du schon getestet?
# Forester 2.0X SG Schalter [ MJ2007 ]

derlucifer

Anfänger

Beiträge: 10

Registrierungsdatum: 26. Oktober 2018

  • Private Nachricht senden

287

Donnerstag, 1. November 2018, 18:44

Ich kann da kein Relais ausmachen worüber das noch laufen soll. Der Schaltstrom für das "Sekundärluft Relais 2", welches zum schalten der Pumpe zuständig ist, führt doch direkt zur ECU.

Nein, die Pumpe konnte ich leider noch nicht testen. Vielleicht finde ich morgen dazu die Zeit.

ampel2

SC+ Mitglied

Beiträge: 1 984

Registrierungsdatum: 18. September 2002

Wohnort: Leipzig

  • Private Nachricht senden

288

Donnerstag, 1. November 2018, 23:35

engl. WEB-Handbuch http://jdmfsm.info/Auto/Japan/Subaru/For…orester%202008/ (am besten mit dem alten I-Explorer öffenen)

Über den Fehler ( DCT P1418 ) kommte man der der Sache auf die Spur:

hier der Schaltplan: http://jdmfsm.info/Auto/Japan/Subaru/For…f/en-04851e.pdf
Es ist zu sehen, dass die Pumpe über das "SECONDARY AIR PUMP RELAY" gesteuert wird. Über Pin B5 der ECU (ECM) muss ein Positiver Schaltimpuls kommen, damit das Relais anzieht.
Das Relais sitzt in einem Relaishalter (F9) mit so einer abgerundeten Ecke.
hier unter WIRING SYSTEM > Power Supply Circuit gibt es die Zeichnung der Relais und Sicherungshalter
http://jdmfsm.info/Auto/Japan/Subaru/For…f/wi-14239e.pdf

Dort gilt es das Air-Pump-Relay zu finden, dann kann gemessen werden, ob überhaupt eine Ansteuerung erfolgt.
Gruß Gerald

Wer Rechtschreibfehler findet, darf sie behalten !!! :rolleyes: "Birsctihe Frshocer hbaen haruesgfnuedn, dass es eagl ist, in whlecer Rhieenfgloe die Behsucbatn eenis Wtores sheten, slognae der etsre und ltetze Bhsucbate am rhitirgcn Pltaz sehten."

Knoten

Fortgeschrittener

Beiträge: 180

Registrierungsdatum: 22. Mai 2014

  • Private Nachricht senden

289

Freitag, 2. November 2018, 00:14

@ ampel2
Danke dir. Sehr ausführlich.

Gut zu wissen das es das alles online gibt. Hätte ich das nicht per PM senden brauchen und gleich hier Posten können :-)
# Forester 2.0X SG Schalter [ MJ2007 ]

derlucifer

Anfänger

Beiträge: 10

Registrierungsdatum: 26. Oktober 2018

  • Private Nachricht senden

290

Freitag, 2. November 2018, 00:33

Erstmal vielen Dank für die vielen Infos.

Also kommt der Schaltimpuls direkt von der ECU.

Das "Air-Pump-Relay" ist doch exakt das Relais, welches wir nehmen um die gebastelte "Austrickselektronik" anzuschließen, oder?
Genau dort habe ich ja schon mehrfach gemessen, mit und ohne Relais eingesteckt, es kommt kein Strom an. Das Relais selber habe ich auch getestet, das schaltet, wenn ich es mit 12V belege, einwandfrei.

Mein Ansatzpunkt wäre jetzt, die Leitung von Relais-Sockel zur ECU auf Durchgang zu prüfen um einen Kabelbruch oder ähnliches auszuschließen.
Wenn das Kabel i.O. ist, muss ja eigentlich die ECU defekt sein, oder liege ich mit dem Denkansatz falsch?


Edit: Was ist denn mit dem "Main-Relay" im Schaltplan? Wenn das nicht funktioniert, dürfte das System auch nicht Schalten. Ich kann aber nicht ganz nachvollziehen, wo ich das im Auto finden kann um es zu prüfen.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »derlucifer« (2. November 2018, 00:39)


Knoten

Fortgeschrittener

Beiträge: 180

Registrierungsdatum: 22. Mai 2014

  • Private Nachricht senden

291

Freitag, 2. November 2018, 03:00

Vergesse nicht auch Masse-Kabel zu prüfen.

Das *Main-Relaiy* wirst du nicht finden. Der Schaltplan ist für MJ 2008. Du hast 2006 oder?
Wenn du bei 2006 guckst ist der Schaltplan der gleiche wie in der PM.


Zitat

Die Pumpe habe ich noch nicht getestet. Sollte ja aber egal sein wenn die Schaltung angeschlossen ist, da ja das Relais ausgebaut ist, welches die Pumpe schalten würde, oder?


Das "Air-Pump-Relay" ist doch exakt das Relais, welches wir nehmen um die gebastelte "Austrickselektronik" anzuschließen, oder?

Was meinst du genau mit anschließen?
Den Strom für die Elektronik holst du dir doch von der Pumpe bzw deren Stecker. Wenn du das Relais ausgebaut hast, dann geht das nicht.
Oder hab ich da jetzt was falsch verstanden?
# Forester 2.0X SG Schalter [ MJ2007 ]

derlucifer

Anfänger

Beiträge: 10

Registrierungsdatum: 26. Oktober 2018

  • Private Nachricht senden

292

Gestern, 07:27

So, leider habe ich nicht viel Zeit gehabt deshalb kann ich erst jetzt wieder eine Statusmeldung geben.

Das Problem ist immer noch nicht gelöst. Was jetzt feststeht ist, das kein Schaltimpuls zum Relais der Pumpe kommt.
Die Kabel vom Relais zum Steuergerät sind auch einwandfrei. Auch das Steuergerät selber sieht einwandfrei aus (Stecker und auch innen).
Ich gehe jetzt mittlerweile von einem Defekt im Steuergerät aus oder es gibt noch etwas was gemessen wird, nicht in Ordnung ist und verhindert das der Schaltimpuls vom Relais kommt.

Denn, mit der Platine funktioniert das normale fahren ohne Fehler, nur beim Kaltstart kommt die Fehlermeldung P1418, da ja das Relais nicht schaltet.

Der einzige Weg der mir jetzt noch einfällt ist, das schalten des Relais auch zu simulieren. Nur dazu müsste ich wissen, wann der Forester sagt das es ein Kaltstart ist und welcher Sensor (vielleicht Kat Temperatur oder Motortemperatur) dafür zuständig ist. Dann ist noch die Frage ob das Sekundärluftsystem dann eine bestimmte Zeit läuft oder auch gebunden an einen Wert ist.
Wenn ich das weiss, ist es recht einfach dafür eine Schaltung zu bauen denke ich.

Vielleicht könnt ihr mir ja hier auch noch weiter helfen!